What’s Vulnerable › Products
Mapster WP Maps vulnerabilities
8 known vulnerabilities, 0 confirmed exploited in the wild (CISA KEV), 6 published in the last 12 months.
Check whether your Mapster WP Maps version is affected
Latest Mapster WP Maps vulnerabilities
- CVE-2026-107743 — Mapster WP Maps <= 2.0.5 - Unauthenticated Stored Cross-Site Scripting via 'config.loading.background' Parameter (CVSS 7.2)
- CVE-2026-39720 — WordPress Mapster WP Maps plugin <= 2.0.4 - Cross Site Scripting (XSS) vulnerability (CVSS 7.1)
- CVE-2026-12954 — Mapster WP Maps <= 1.23.0 - Authenticated (Subscriber+) Arbitrary User Meta Write via 'acf-photo-gallery-groups' Parameter (CVSS 8.8)
- CVE-2024-13362 — Freemius <= 2.10.1 - Reflected DOM-Based Cross-Site Scripting via url Parameter (CVSS 6.1)
- CVE-2025-9044 — Mapster WP Maps <= 1.20.0 - Authenticated (Contributor+) Stored Cross-Site Scripting (CVSS 6.4)
- CVE-2024-10592 — Mapster WP Maps <= 1.6.0 - Authenticated (Contributor+) Stored Cross-Site Scripting (CVSS 6.4)
- CVE-2024-9235 — Mapster WP Maps <= 1.5.0 - Incorrect Authorization to Authenticated (Contributor+) Arbitrary Options Update (CVSS 8.8)
- CVE-2024-21744 — WordPress Mapster WP Maps Plugin <= 1.2.38 is vulnerable to Cross Site Scripting (XSS) (CVSS 5.4)