What’s Vulnerable › Vulnerabilities
CVE-2001-0191
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2001-05-03 · updated 2026-06-16
- Weakness: CWE-120
Description
gnuserv before 3.12, as shipped with XEmacs, does not properly check the specified length of an X Windows MIT-MAGIC-COOKIE cookie, which allows remote attackers to execute arbitrary commands via a buffer overflow, or brute force authentication by using a short cookie length.
Affected products
- Andynorman Gnuserv: before 3.12 — fixed in 3.12
How to fix
Upgrade to a fixed version: Andynorman Gnuserv 3.12. Check the vendor advisory for mitigations.
References
- http://archives.neohapsis.com/archives/bugtraq/2001-02/0030.html
- http://www.linux-mandrake.com/en/security/2001/MDKSA-2001-019.php3
- http://www.redhat.com/support/errata/RHSA-2001-010.html
- http://www.redhat.com/support/errata/RHSA-2001-011.html
- https://exchange.xforce.ibmcloud.com/vulnerabilities/6056
- http://archives.neohapsis.com/archives/bugtraq/2001-02/0030.html
- http://www.linux-mandrake.com/en/security/2001/MDKSA-2001-019.php3
- http://www.redhat.com/support/errata/RHSA-2001-010.html
- http://www.redhat.com/support/errata/RHSA-2001-011.html
- https://exchange.xforce.ibmcloud.com/vulnerabilities/6056
Get alerted when CVE-2001-0191 or the next vulnerability affects your stack