What’s Vulnerable › Vulnerabilities
CVE-2001-1323
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2001-05-16 · updated 2026-06-16
- Weakness: CWE-120
Description
Buffer overflow in MIT Kerberos 5 (krb5) 1.2.2 and earlier allows remote attackers to cause a denial of service and possibly execute arbitrary code via base-64 encoded data, which is not properly handled when the radix_encode function processes file glob output from the ftpglob function.
Affected products
- MIT Kerberos 5: before 1.2.2 — fixed in 1.2.2
How to fix
Upgrade to a fixed version: MIT Kerberos 5 1.2.2. Check the vendor advisory for mitigations.
References
- http://download.immunix.org/ImmunixOS/7.0/updates/IMNX-2001-70-022-01
- http://marc.info/?l=bugtraq&m=98826223517788&w=2
- http://web.mit.edu/kerberos/www/advisories/ftpbuf.txt
- http://www.redhat.com/support/errata/RHSA-2001-060.html
- http://download.immunix.org/ImmunixOS/7.0/updates/IMNX-2001-70-022-01
- http://marc.info/?l=bugtraq&m=98826223517788&w=2
- http://web.mit.edu/kerberos/www/advisories/ftpbuf.txt
- http://www.redhat.com/support/errata/RHSA-2001-060.html
Get alerted when CVE-2001-1323 or the next vulnerability affects your stack