What’s Vulnerable › Vulnerabilities
CVE-2002-0062
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2002-03-08 · updated 2026-07-23
- Weakness: CWE-120
Description
Buffer overflow in ncurses 5.0, and the ncurses4 compatibility package as used in Red Hat Linux, allows local users to gain privileges, related to "routines for moving the physical cursor and scrolling."
Affected products
- Debian Linux: 2.2
- FreeBSD: 3.1, 3.2, 3.3, 3.4, 3.5, 3.5.1 (+4)
- GNU ncurses: before 5.0 — fixed in 5.0
- RedHat Linux: 6.1, 7.0, 7.1, 7.2
- Suse Linux: 6.2, 6.3, 7.0
How to fix
Upgrade to a fixed version: GNU ncurses 5.0. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2002/dsa-113
- http://www.iss.net/security_center/static/8222.php
- http://www.redhat.com/support/errata/RHSA-2002-020.html
- http://www.securityfocus.com/bid/2116
- http://www.debian.org/security/2002/dsa-113
- http://www.iss.net/security_center/static/8222.php
- http://www.redhat.com/support/errata/RHSA-2002-020.html
- http://www.securityfocus.com/bid/2116
Get alerted when CVE-2002-0062 or the next vulnerability affects your stack