What’s Vulnerable › Vulnerabilities
CVE-2002-0184
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2002-05-16 · updated 2026-06-16
- Weakness: CWE-131
Description
Sudo before 1.6.6 contains an off-by-one error that can result in a heap-based buffer overflow that may allow local users to gain root privileges via special characters in the -p (prompt) argument, which are not properly expanded.
Affected products
- Debian Linux: 2.2
- sudo: before 1.6.6 — fixed in 1.6.6
How to fix
Upgrade to a fixed version: sudo 1.6.6. Check the vendor advisory for mitigations.
References
- http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000475
- http://marc.info/?l=bugtraq&m=101974610509912&w=2
- http://marc.info/?l=bugtraq&m=101975443619600&w=2
- http://marc.info/?l=bugtraq&m=101979472822196&w=2
- http://marc.info/?l=bugtraq&m=102010164413135&w=2
- http://marc.info/?l=bugtraq&m=102010164413135&w=2
- http://marc.info/?l=bugtraq&m=102010164413135&w=2
- http://marc.info/?l=bugtraq&m=102010164413135&w=2
- http://www.debian.org/security/2002/dsa-128
- http://www.iss.net/security_center/static/8936.php
- http://www.kb.cert.org/vuls/id/820083
- http://www.linux-mandrake.com/en/security/2002/MDKSA-2002-028.php3
Get alerted when CVE-2002-0184 or the next vulnerability affects your stack