What’s Vulnerable › Vulnerabilities
CVE-2002-0844
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2002-08-12 · updated 2026-06-16
- Weakness: CWE-193
Description
Off-by-one overflow in the CVS PreservePermissions of rcs.c for CVSD before 1.11.2 allows local users to execute arbitrary code.
Affected products
- Distrotech Cvs: before 1.11.2 — fixed in 1.11.2
How to fix
Upgrade to a fixed version: Distrotech Cvs 1.11.2. Check the vendor advisory for mitigations.
References
- http://archives.neohapsis.com/archives/vulnwatch/2002-q2/0081.html
- http://marc.info/?l=bugtraq&m=102233767925177&w=2
- http://www.redhat.com/support/errata/RHSA-2004-004.html
- http://www.securityfocus.com/bid/4829
- https://exchange.xforce.ibmcloud.com/vulnerabilities/9175
- http://archives.neohapsis.com/archives/vulnwatch/2002-q2/0081.html
- http://marc.info/?l=bugtraq&m=102233767925177&w=2
- http://www.redhat.com/support/errata/RHSA-2004-004.html
Get alerted when CVE-2002-0844 or the next vulnerability affects your stack