What’s Vulnerable › Vulnerabilities

CVE-2002-0969

Description

Buffer overflow in MySQL daemon (mysqld) before 3.23.50, and 4.0 beta before 4.02, on the Win32 platform, allows local users to execute arbitrary code via a long "datadir" parameter in the my.ini initialization file, whose permissions on Windows allow Full Control to the Everyone group.

Affected products

How to fix

Upgrade to a fixed version: MySQL Server 3.23.50. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2002-0969 or the next vulnerability affects your stack