What’s Vulnerable › Vulnerabilities
CVE-2002-1235
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 15.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2002-11-04 · updated 2026-06-16
Description
The kadm_ser_in function in (1) the Kerberos v4compatibility administration daemon (kadmind4) in the MIT Kerberos 5 (krb5) krb5-1.2.6 and earlier, (2) kadmind in KTH Kerberos 4 (eBones) before 1.2.1, and (3) kadmind in KTH Kerberos 5 (Heimdal) before 0.5.1 when compiled with Kerberos 4 support, does not properly verify the length field of a request, which allows remote attackers to execute arbitrary code via a buffer overflow attack.
Affected products
- Debian Linux: 3.0
- Kth Kerberos 4: before 1.2.1 — fixed in 1.2.1
- Kth Kerberos 5: before 0.5.1 — fixed in 0.5.1
- MIT Kerberos 5: from 1.0 through 1.2.6
How to fix
Upgrade to a fixed version: Kth Kerberos 4 1.2.1; Kth Kerberos 5 0.5.1. Check the vendor advisory for mitigations.
References
- http://archives.neohapsis.com/archives/bugtraq/2002-10/0399.html
- http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000534
- http://marc.info/?l=bugtraq&m=103539530729206&w=2
- http://marc.info/?l=bugtraq&m=103564944215101&w=2
- http://marc.info/?l=bugtraq&m=103582517126392&w=2
- http://marc.info/?l=bugtraq&m=103582805330339&w=2
- http://web.mit.edu/kerberos/www/advisories/2002-002-kadm4_attacksig.txt
- http://web.mit.edu/kerberos/www/advisories/MITKRB5-SA-2002-002-kadm4.txt
- http://www.cert.org/advisories/CA-2002-29.html
- http://www.debian.org/security/2002/dsa-183
- http://www.debian.org/security/2002/dsa-184
Get alerted when CVE-2002-1235 or the next vulnerability affects your stack