What’s Vulnerable › Vulnerabilities
CVE-2003-0020
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2003-03-18 · updated 2026-06-16
Description
Apache does not filter terminal escape sequences from its error logs, which could make it easier for attackers to insert those sequences into terminal emulators containing vulnerabilities related to escape sequences.
Affected products
- Apache HTTP Server: from 1.3.0 before 1.3.31; from 2.0.0 before 2.0.49 — fixed in 1.3.31, 2.0.49
How to fix
Upgrade to a fixed version: Apache HTTP Server 1.3.31, 2.0.49. Check the vendor advisory for mitigations.
References
- http://archives.neohapsis.com/archives/vulnwatch/2003-q1/0093.html
- http://frontal2.mandriva.com/security/advisories?name=MDKSA-2004:046
- http://marc.info/?l=bugtraq&m=104612710031920&w=2
- http://marc.info/?l=bugtraq&m=108369640424244&w=2
- http://marc.info/?l=bugtraq&m=108437852004207&w=2
- http://marc.info/?l=bugtraq&m=108731648532365&w=2
- http://security.gentoo.org/glsa/glsa-200405-22.xml
- http://sunsolve.sun.com/search/document.do?assetkey=1-26-101555-1
- http://sunsolve.sun.com/search/document.do?assetkey=1-26-57628-1
- http://www.iss.net/security_center/static/11412.php
- http://www.mandrakesoft.com/security/advisories?name=MDKSA-2003:050
- http://www.redhat.com/support/errata/RHSA-2003-082.html
Get alerted when CVE-2003-0020 or the next vulnerability affects your stack