What’s Vulnerable › Vulnerabilities
CVE-2003-1013
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2004-01-05 · updated 2026-06-16
- Weakness: CWE-476
Description
The Q.931 dissector in Ethereal before 0.10.0, and Tethereal, allows remote attackers to cause a denial of service (crash) via a malformed Q.931, which triggers a null dereference.
Affected products
- Ethereal: before 0.10.0 — fixed in 0.10.0
How to fix
Upgrade to a fixed version: Ethereal 0.10.0. Check the vendor advisory for mitigations.
References
- http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000801
- http://secunia.com/advisories/10531
- http://secunia.com/advisories/10568
- http://secunia.com/advisories/10570
- http://www.debian.org/security/2003/dsa-407
- http://www.ethereal.com/appnotes/enpa-sa-00012.html
- http://www.mandriva.com/security/advisories?name=MDKSA-2004:002
- http://www.redhat.com/support/errata/RHSA-2004-001.html
- http://www.redhat.com/support/errata/RHSA-2004-002.html
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10097
Get alerted when CVE-2003-1013 or the next vulnerability affects your stack