What’s Vulnerable › Vulnerabilities
CVE-2004-0150
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2004-04-15 · updated 2026-06-16
- Weakness: CWE-120
Description
Buffer overflow in the getaddrinfo function in Python 2.2 before 2.2.2, when IPv6 support is disabled, allows remote attackers to execute arbitrary code via an IPv6 address that is obtained using DNS.
Affected products
- Python: from 2.2.0 before 2.2.2 — fixed in 2.2.2
How to fix
Upgrade to a fixed version: Python 2.2.2. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2004/dsa-458
- http://www.gentoo.org/security/en/glsa/glsa-200409-03.xml
- http://www.mandrakesoft.com/security/advisories?name=MDKSA-2004:019
- http://www.osvdb.org/4172
- http://www.securityfocus.com/bid/9836
- https://exchange.xforce.ibmcloud.com/vulnerabilities/15409
- http://www.debian.org/security/2004/dsa-458
- http://www.gentoo.org/security/en/glsa/glsa-200409-03.xml
- http://www.mandrakesoft.com/security/advisories?name=MDKSA-2004:019
- http://www.osvdb.org/4172
- http://www.securityfocus.com/bid/9836
- https://exchange.xforce.ibmcloud.com/vulnerabilities/15409
Get alerted when CVE-2004-0150 or the next vulnerability affects your stack