What’s Vulnerable › Vulnerabilities
CVE-2004-0434
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2004-07-07 · updated 2026-06-16
- Weakness: CWE-131
Description
k5admind (kadmind) for Heimdal allows remote attackers to execute arbitrary code via a Kerberos 4 compatibility administration request whose framing length is less than 2, which leads to a heap-based buffer overflow.
Affected products
- Debian Linux: 3.0
- Heimdal Software Kerberos: before 0.6.2 — fixed in 0.6.2
How to fix
Upgrade to a fixed version: Heimdal Software Kerberos 0.6.2. Check the vendor advisory for mitigations.
References
- http://lists.grok.org.uk/pipermail/full-disclosure/2004-May/020998.html
- http://marc.info/?l=bugtraq&m=108386148126457&w=2
- http://security.gentoo.org/glsa/glsa-200405-23.xml
- http://www.debian.org/security/2004/dsa-504
- https://exchange.xforce.ibmcloud.com/vulnerabilities/16071
- http://lists.grok.org.uk/pipermail/full-disclosure/2004-May/020998.html
- http://marc.info/?l=bugtraq&m=108386148126457&w=2
- http://security.gentoo.org/glsa/glsa-200405-23.xml
- http://www.debian.org/security/2004/dsa-504
- https://exchange.xforce.ibmcloud.com/vulnerabilities/16071
Get alerted when CVE-2004-0434 or the next vulnerability affects your stack