What’s Vulnerable › Vulnerabilities
CVE-2004-0455
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2004-12-06 · updated 2026-06-16
- Weakness: CWE-120
Description
Buffer overflow in cgi.c in www-sql before 0.5.7 allows local users to execute arbitrary code via a web page that is processed by www-sql.
Affected products
- Debian Linux: 3.0
- Www-Sql Project Www-Sql: before 0.5.7 — fixed in 0.5.7
How to fix
Upgrade to a fixed version: Www-Sql Project Www-Sql 0.5.7. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2004/dsa-523
- http://www.securityfocus.com/bid/10577
- https://exchange.xforce.ibmcloud.com/vulnerabilities/16455
- http://www.debian.org/security/2004/dsa-523
- http://www.securityfocus.com/bid/10577
- https://exchange.xforce.ibmcloud.com/vulnerabilities/16455
Get alerted when CVE-2004-0455 or the next vulnerability affects your stack