What’s Vulnerable › Vulnerabilities
CVE-2004-0488
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 37.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2004-07-07 · updated 2026-06-16
- Weakness: CWE-787
Description
Stack-based buffer overflow in the ssl_util_uuencode_binary function in ssl_util.c for Apache mod_ssl, when mod_ssl is configured to trust the issuing CA, may allow remote attackers to execute arbitrary code via a client certificate with a long subject DN.
Affected products
- Apache HTTP Server: from 2.0.35 before 2.0.50 — fixed in 2.0.50
- Debian Linux: 3.0
- RedHat Enterprise Linux Server: 2.0
- RedHat Enterprise Linux Workstation: 2.0
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.0.50. Check the vendor advisory for mitigations.
References
- http://lists.grok.org.uk/pipermail/full-disclosure/2004-May/021610.html
- http://marc.info/?l=bugtraq&m=108567431823750&w=2
- http://marc.info/?l=bugtraq&m=108619129727620&w=2
- http://marc.info/?l=bugtraq&m=109181600614477&w=2
- http://marc.info/?l=bugtraq&m=109215056218824&w=2
- http://rhn.redhat.com/errata/RHSA-2004-245.html
- http://security.gentoo.org/glsa/glsa-200406-05.xml
- http://www.debian.org/security/2004/dsa-532
- http://www.mandriva.com/security/advisories?name=MDKSA-2004:054
- http://www.mandriva.com/security/advisories?name=MDKSA-2004:055
- http://www.redhat.com/support/errata/RHSA-2004-342.html
Get alerted when CVE-2004-0488 or the next vulnerability affects your stack