What’s Vulnerable › Vulnerabilities
CVE-2004-0594
- Severity: medium (CVSS 5.1 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 54.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2004-07-27 · updated 2026-06-16
- Weakness: CWE-367
Description
The memory_limit functionality in PHP 4.x up to 4.3.7, and 5.x up to 5.0.0RC3, under certain conditions such as when register_globals is enabled, allows remote attackers to execute arbitrary code by triggering a memory_limit abort during execution of the zend_hash_init function and overwriting a HashTable destructor pointer before the initialization of key data structures is complete.
Affected products
- Avaya Converged Communications Server: 2.0
- Debian Linux: 3.0
- Hewlett Packard Enterprise (HPE) HP-UX: b.11.00, b.11.11, b.11.22, b.11.23
- Openpkg: 2.0, 2.1
- PHP: from 4.0 before 4.3.7; 5.0.0-beta1, 5.0.0-beta2, 5.0.0-beta3, 5.0.0-beta4, 5.0.0-rc1, 5.0.0-rc2 — fixed in 4.3.7
- Trustix Secure Linux: 1.5, 2.0, 2.1
How to fix
Upgrade to a fixed version: PHP 4.3.7. Check the vendor advisory for mitigations.
References
- http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000847
- http://lists.grok.org.uk/pipermail/full-disclosure/2004-July/023908.html
- http://marc.info/?l=bugtraq&m=108981780109154&w=2
- http://marc.info/?l=bugtraq&m=108982983426031&w=2
- http://marc.info/?l=bugtraq&m=109051444105182&w=2
- http://marc.info/?l=bugtraq&m=109181600614477&w=2
- http://www.debian.org/security/2004/dsa-531
- http://www.debian.org/security/2005/dsa-669
- http://www.gentoo.org/security/en/glsa/glsa-200407-13.xml
- http://www.mandrakesecure.net/en/advisories/advisory.php?name=MDKSA-2004:068
- http://www.novell.com/linux/security/advisories/2004_21_php4.html
- http://www.redhat.com/support/errata/RHSA-2004-392.html
Get alerted when CVE-2004-0594 or the next vulnerability affects your stack