What’s Vulnerable › Vulnerabilities
CVE-2004-0747
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2004-10-20 · updated 2026-06-16
- Weakness: CWE-131
Description
Buffer overflow in Apache 2.0.50 and earlier allows local users to gain apache privileges via a .htaccess file that causes the overflow during expansion of environment variables.
Affected products
- Apache HTTP Server: from 2.0.35 before 2.0.51 — fixed in 2.0.51
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.0.51. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/12540
- http://secunia.com/advisories/34920
- http://securitytracker.com/id?1011303
- http://support.ca.com/irj/portal/anonymous/phpsupcontent?contentID=205147
- http://www.gentoo.org/security/en/glsa/glsa-200409-21.xml
- http://www.kb.cert.org/vuls/id/481998
- http://www.mandrakesecure.net/en/advisories/advisory.php?name=MDKSA-2004:096
- http://www.novell.com/linux/security/advisories/2004_32_apache2.html
- http://www.redhat.com/support/errata/RHSA-2004-463.html
- http://www.trustix.org/errata/2004/0047/
- http://www.vupen.com/english/advisories/2009/1233
- https://exchange.xforce.ibmcloud.com/vulnerabilities/17384
Get alerted when CVE-2004-0747 or the next vulnerability affects your stack