What’s Vulnerable › Vulnerabilities
CVE-2004-0786
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 24.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2004-10-20 · updated 2026-06-16
Description
The IPv6 URI parsing routines in the apr-util library for Apache 2.0.50 and earlier allow remote attackers to cause a denial of service (child process crash) via a certain URI, as demonstrated using the Codenomicon HTTP Test Tool.
Affected products
- Apache HTTP Server: from 2.0.35 before 2.0.51 — fixed in 2.0.51
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.0.51. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/12540
- http://www.gentoo.org/security/en/glsa/glsa-200409-21.xml
- http://www.mandrakesecure.net/en/advisories/advisory.php?name=MDKSA-2004:096
- http://www.novell.com/linux/security/advisories/2004_32_apache2.html
- http://www.redhat.com/support/errata/RHSA-2004-463.html
- http://www.trustix.org/errata/2004/0047/
- https://exchange.xforce.ibmcloud.com/vulnerabilities/17382
- https://lists.apache.org/thread.html/54a42d4b01968df1117cea77fc53d6beb931c0e05936ad02af93e9ac%40%3Ccvs.httpd.apache.org%3E
- https://lists.apache.org/thread.html/5df9bfb86a3b054bb985a45ff9250b0332c9ecc181eec232489e7f79%40%3Ccvs.httpd.apache.org%3E
- https://lists.apache.org/thread.html/r0276683d8e1e07153fc8642618830ac0ade85b9ae0dc7b07f63bb8fc%40%3Ccvs.httpd.apache.org%3E
- https://lists.apache.org/thread.html/r2cb985de917e7da0848c440535f65a247754db8b2154a10089e4247b%40%3Ccvs.httpd.apache.org%3E
- https://lists.apache.org/thread.html/r5001ecf3d6b2bdd0b732e527654248abb264f08390045d30709a92f6%40%3Ccvs.httpd.apache.org%3E
Get alerted when CVE-2004-0786 or the next vulnerability affects your stack