What’s Vulnerable › Vulnerabilities
CVE-2004-0816
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2004-12-23 · updated 2026-06-16
- Weakness: CWE-191
Description
Integer underflow in the firewall logging rules for iptables in Linux before 2.6.8 allows remote attackers to cause a denial of service (application crash) via a malformed IP packet.
Affected products
- Linux kernel: before 2.6.8 — fixed in 2.6.8
How to fix
Upgrade to a fixed version: Linux kernel 2.6.8. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/11202/
- http://www.mandriva.com/security/advisories?name=MDKSA-2005:022
- http://www.novell.com/linux/security/advisories/2004_37_kernel.html
- http://www.securityfocus.com/bid/11488
- https://exchange.xforce.ibmcloud.com/vulnerabilities/17800
- http://secunia.com/advisories/11202/
- http://www.mandriva.com/security/advisories?name=MDKSA-2005:022
- http://www.novell.com/linux/security/advisories/2004_37_kernel.html
- http://www.securityfocus.com/bid/11488
- https://exchange.xforce.ibmcloud.com/vulnerabilities/17800
Get alerted when CVE-2004-0816 or the next vulnerability affects your stack