What’s Vulnerable › Vulnerabilities

CVE-2004-0835

Description

MySQL 3.x before 3.23.59, 4.x before 4.0.19, 4.1.x before 4.1.2, and 5.x before 5.0.1, checks the CREATE/INSERT rights of the original table instead of the target table in an ALTER TABLE RENAME operation, which could allow attackers to conduct unauthorized activities.

Affected products

How to fix

Upgrade to a fixed version: MySQL Server 3.23.59, 4.0.19. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2004-0835 or the next vulnerability affects your stack