What’s Vulnerable › Vulnerabilities
CVE-2004-0837
- Severity: low (CVSS 2.6 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2004-11-03 · updated 2026-06-16
Description
MySQL 4.x before 4.0.21, and 3.x before 3.23.49, allows attackers to cause a denial of service (crash or hang) via multiple threads that simultaneously alter MERGE table UNIONs.
Affected products
- Debian Linux: 3.0
- Mysql: 4.1.0
- MySQL Server: from 3.20 before 3.23.49; from 4.0.0 before 4.0.21 — fixed in 3.23.49, 4.0.21
How to fix
Upgrade to a fixed version: MySQL Server 3.23.49, 4.0.21. Check the vendor advisory for mitigations.
References
- http://bugs.mysql.com/2408
- http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000892
- http://lists.mysql.com/internals/16168
- http://lists.mysql.com/internals/16173
- http://lists.mysql.com/internals/16174
- http://marc.info/?l=bugtraq&m=110140517515735&w=2
- http://mysql.bkbits.net:8080/mysql-3.23/diffs/myisammrg/myrg_open.c%401.15
- http://secunia.com/advisories/12783/
- http://securitytracker.com/id?1011606
- http://sunsolve.sun.com/search/document.do?assetkey=1-26-101864-1
- http://www.ciac.org/ciac/bulletins/p-018.shtml
- http://www.debian.org/security/2004/dsa-562
Get alerted when CVE-2004-0837 or the next vulnerability affects your stack