What’s Vulnerable › Vulnerabilities

CVE-2004-0977

Description

The make_oidjoins_check script in PostgreSQL 7.4.5 and earlier allows local users to overwrite files via a symlink attack on temporary files.

Affected products

How to fix

Upgrade to a fixed version: PostgreSQL 7.3.8, 7.4.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2004-0977 or the next vulnerability affects your stack