What’s Vulnerable › Vulnerabilities
CVE-2004-1018
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2005-01-10 · updated 2026-06-16
Description
Multiple integer handling errors in PHP before 4.3.10 allow attackers to bypass safe mode restrictions, cause a denial of service, or execute arbitrary code via (1) a negative offset value to the shmop_write function, (2) an "integer overflow/underflow" in the pack function, or (3) an "integer overflow/underflow" in the unpack function. NOTE: this issue was originally REJECTed by its CNA before publication, but that decision is in active dispute. This candidate may change significantly in the future as a result of further discussion.
Affected products
- Canonical Ubuntu Linux: 4.10
- PHP: before 4.3.10 — fixed in 4.3.10
How to fix
Upgrade to a fixed version: PHP 4.3.10. Check the vendor advisory for mitigations.
References
- http://marc.info/?l=bugtraq&m=110314318531298&w=2
- http://www.hardened-php.net/advisories/012004.txt
- http://www.mandriva.com/security/advisories?name=MDKSA-2004:151
- http://www.mandriva.com/security/advisories?name=MDKSA-2005:072
- http://www.osvdb.org/12411
- http://www.php.net/release_4_3_10.php
- http://www.redhat.com/support/errata/RHSA-2005-032.html
- http://www.redhat.com/support/errata/RHSA-2005-816.html
- http://www.securityfocus.com/advisories/9028
- http://www.securityfocus.com/archive/1/384920
- http://www.securityfocus.com/bid/12045
- https://bugzilla.fedora.us/show_bug.cgi?id=2344
Get alerted when CVE-2004-1018 or the next vulnerability affects your stack