What’s Vulnerable › Vulnerabilities
CVE-2004-1901
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2004-12-31 · updated 2026-06-16
- Weakness: CWE-59
Description
Portage before 2.0.50-r3 allows local users to overwrite arbitrary files via a hard link attack on the lockfiles.
Affected products
- gentoo Linux: 1.4, 1.4-rc1, 1.4-rc2
- gentoo Portage: before 2.0.50; 2.0.50 — fixed in 2.0.50
How to fix
Upgrade to a fixed version: gentoo Portage 2.0.50. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/11305
- http://security.gentoo.org/glsa/glsa-200404-01.xml
- http://www.securityfocus.com/bid/10060
- https://exchange.xforce.ibmcloud.com/vulnerabilities/15754
- http://secunia.com/advisories/11305
- http://security.gentoo.org/glsa/glsa-200404-01.xml
- http://www.securityfocus.com/bid/10060
- https://exchange.xforce.ibmcloud.com/vulnerabilities/15754
Get alerted when CVE-2004-1901 or the next vulnerability affects your stack