What’s Vulnerable › Vulnerabilities
CVE-2004-2154
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2004-12-31 · updated 2026-06-16
- Weakness: CWE-178
Description
CUPS before 1.1.21rc1 treats a Location directive in cupsd.conf as case sensitive, which allows attackers to bypass intended ACLs via a printer name containing uppercase or lowercase letters that are different from what is specified in the directive.
Affected products
- cups: before 1.1.21; 1.1.21 — fixed in 1.1.21
- Canonical Ubuntu Linux: 4.10
How to fix
Upgrade to a fixed version: cups 1.1.21. Check the vendor advisory for mitigations.
References
- http://www.cups.org/str.php?L700
- http://www.novell.com/linux/security/advisories/2005_18_sr.html
- http://www.redhat.com/support/errata/RHSA-2005-571.html
- http://www.ubuntu.com/usn/usn-185-1
- https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=162405
- https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=163274
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9940
- http://www.cups.org/str.php?L700
- http://www.novell.com/linux/security/advisories/2005_18_sr.html
- http://www.redhat.com/support/errata/RHSA-2005-571.html
- http://www.ubuntu.com/usn/usn-185-1
- https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=162405
Get alerted when CVE-2004-2154 or the next vulnerability affects your stack