What’s Vulnerable › Vulnerabilities
CVE-2004-2172
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2004-12-31 · updated 2026-06-16
- Weakness: CWE-326
Description
EarlyImpact ProductCart uses a weak encryption scheme to encrypt passwords, which allows remote attackers to obtain the password via a chosen plaintext attack.
Affected products
- Netsourcecommerce Productcart: before 2.53 — fixed in 2.53
How to fix
Upgrade to a fixed version: Netsourcecommerce Productcart 2.53. Check the vendor advisory for mitigations.
References
- http://archives.neohapsis.com/archives/bugtraq/2004-02/0503.html
- http://archives.neohapsis.com/archives/fulldisclosure/2004-02/0871.html
- http://secunia.com/advisories/10898
- http://securitytracker.com/alerts/2004/Feb/1009085.html
- http://www.earlyimpact.com/productcart/support/updates/ReadMe_ProductCart_Security_Patch_013004.txt
- http://www.osvdb.org/3979
- http://www.s-quadra.com/advisories/Adv-20040216.txt
- http://www.securityfocus.com/archive/1/354288
- http://www.securityfocus.com/bid/9669
- https://exchange.xforce.ibmcloud.com/vulnerabilities/15231
- http://archives.neohapsis.com/archives/bugtraq/2004-02/0503.html
- http://archives.neohapsis.com/archives/fulldisclosure/2004-02/0871.html
Get alerted when CVE-2004-2172 or the next vulnerability affects your stack