What’s Vulnerable › Vulnerabilities
CVE-2005-0227
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2005-05-02 · updated 2026-06-16
- Weakness: CWE-94
Description
PostgreSQL (pgsql) 7.4.x, 7.2.x, and other versions allows local users to load arbitrary shared libraries and execute code via the LOAD extension.
Affected products
- PostgreSQL: from 7.3.0 before 7.3.9; from 7.4 before 7.4.7; from 8.0 before 8.0.1 — fixed in 7.3.9, 7.4.7, 8.0.1
How to fix
Upgrade to a fixed version: PostgreSQL 7.3.9, 7.4.7, 8.0.1. Check the vendor advisory for mitigations.
References
- http://archives.postgresql.org/pgsql-announce/2005-02/msg00000.php
- http://archives.postgresql.org/pgsql-bugs/2005-01/msg00269.php
- http://marc.info/?l=bugtraq&m=110726899107148&w=2
- http://secunia.com/advisories/12948
- http://security.gentoo.org/glsa/glsa-200502-08.xml
- http://www.debian.org/security/2005/dsa-668
- http://www.mandriva.com/security/advisories?name=MDKSA-2005:040
- http://www.novell.com/linux/security/advisories/2005_36_sudo.html
- http://www.redhat.com/support/errata/RHSA-2005-138.html
- http://www.redhat.com/support/errata/RHSA-2005-150.html
- http://www.securityfocus.com/bid/12411
- http://www.trustix.org/errata/2005/0003/
Get alerted when CVE-2005-0227 or the next vulnerability affects your stack