What’s Vulnerable › Vulnerabilities

CVE-2005-0245

Description

Buffer overflow in gram.y for PostgreSQL 8.0.0 and earlier may allow attackers to execute arbitrary code via a large number of arguments to a refcursor function (gram.y), which leads to a heap-based buffer overflow, a different vulnerability than CVE-2005-0247.

Affected products

How to fix

Upgrade to a fixed version: PostgreSQL 7.3.10, 7.4.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2005-0245 or the next vulnerability affects your stack