What’s Vulnerable › Vulnerabilities
CVE-2005-0891
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2005-05-02 · updated 2026-06-16
- Weakness: CWE-415
Description
Double free vulnerability in gtk 2 (gtk2) before 2.2.4 allows remote attackers to cause a denial of service (crash) via a crafted BMP image.
Affected products
- GNOME Gtk: from 2.0.0 before 2.2.4 — fixed in 2.2.4
How to fix
Upgrade to a fixed version: GNOME Gtk 2.2.4. Check the vendor advisory for mitigations.
References
- http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000958
- http://secunia.com/advisories/17657
- http://www.mandriva.com/security/advisories?name=MDKSA-2005:214
- http://www.redhat.com/support/errata/RHSA-2005-343.html
- http://www.redhat.com/support/errata/RHSA-2005-344.html
- http://www.securityfocus.com/archive/1/419771/100/0/threaded
- http://www.securityfocus.com/bid/12950
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9710
- http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000958
- http://secunia.com/advisories/17657
- http://www.mandriva.com/security/advisories?name=MDKSA-2005:214
- http://www.redhat.com/support/errata/RHSA-2005-343.html
Get alerted when CVE-2005-0891 or the next vulnerability affects your stack