What’s Vulnerable › Vulnerabilities
CVE-2005-10004: Cacti graph_view.php RCE via graph_start Parameter Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-30 · updated 2026-09-23
- Weakness: CWE-78
Description
Cacti versions prior to 0.8.6-d contain a remote command execution vulnerability in the graph_view.php script. An authenticated user can inject arbitrary shell commands via the graph_start GET parameter, which is improperly handled during graph rendering. This flaw allows attackers to execute commands on the underlying operating system with the privileges of the web server process, potentially compromising system integrity.
Affected products
- cacti: before 0.8.6d — fixed in 0.8.6d
How to fix
Upgrade to a fixed version: cacti 0.8.6d. Check the vendor advisory for mitigations.
References
- https://raw.githubusercontent.com/rapid7/metasploit-framework/master/modules/exploits/unix/webapp/cacti_graphimage_exec.rb
- https://web.archive.org/web/20050305034552/http://www.cacti.net/cactid_download.php
- https://www.cacti.net/info/downloads
- https://www.exploit-db.com/exploits/16881
- https://www.exploit-db.com/exploits/9911
- https://www.vulncheck.com/advisories/cacti-graph-view-rce
Get alerted when CVE-2005-10004 or the next vulnerability affects your stack