What’s Vulnerable › Vulnerabilities
CVE-2005-1654
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2005-05-18 · updated 2026-06-16
- Weakness: CWE-425
Description
Hosting Controller 6.1 Hotfix 1.9 and earlier allows remote attackers to register arbitrary users via a direct request to addsubsite.asp with the loginname and password parameters set.
Affected products
- Hostingcontroller Hosting Controller: before 6.1; 6.1, 6.1-hotfix1.0, 6.1-hotfix1.1, 6.1-hotfix1.2, 6.1-hotfix1.3, 6.1-hotfix1.4 (+5) — fixed in 6.1
How to fix
Upgrade to a fixed version: Hostingcontroller Hosting Controller 6.1. Check the vendor advisory for mitigations.
References
- http://isun.shabgard.org/hc3.txt
- http://secunia.com/advisories/15271
- http://isun.shabgard.org/hc3.txt
- http://secunia.com/advisories/15271
Get alerted when CVE-2005-1654 or the next vulnerability affects your stack