What’s Vulnerable › Vulnerabilities
CVE-2005-1796
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2005-05-31 · updated 2026-06-16
Description
Format string vulnerability in the curses_msg function in the Ncurses interface (ec_curses.c) for Ettercap before 0.7.3 allows remote attackers to execute arbitrary code.
Affected products
- Debian Linux: 3.0, 3.1
- ettercap: before 0.7.3 — fixed in 0.7.3
How to fix
Upgrade to a fixed version: ettercap 0.7.3. Check the vendor advisory for mitigations.
References
- http://ettercap.sourceforge.net/history.php
- http://secunia.com/advisories/15535
- http://secunia.com/advisories/15664
- http://secunia.com/advisories/16000
- http://securitytracker.com/id?1014084
- http://www.debian.org/security/2005/dsa-749
- http://www.gentoo.org/security/en/glsa/glsa-200506-07.xml
- http://www.securityfocus.com/bid/13820
- http://www.vupen.com/english/advisories/2005/0670
- http://ettercap.sourceforge.net/history.php
- http://secunia.com/advisories/15535
- http://secunia.com/advisories/15664
Get alerted when CVE-2005-1796 or the next vulnerability affects your stack