What’s Vulnerable › Vulnerabilities

CVE-2005-1921

Description

Eval injection vulnerability in PEAR XML_RPC 1.3.0 and earlier (aka XML-RPC or xmlrpc) and PHPXMLRPC (aka XML-RPC For PHP or php-xmlrpc) 1.1 and earlier, as used in products such as (1) WordPress, (2) Serendipity, (3) Drupal, (4) egroupware, (5) MailWatch, (6) TikiWiki, (7) phpWebSite, (8) Ampache, and others, allows remote attackers to execute arbitrary PHP code via an XML file, which is not properly sanitized before being used in an eval statement.

Affected products

How to fix

Upgrade to a fixed version: Drupal 4.5.4, 4.6.2; Tiki 1.8.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2005-1921 or the next vulnerability affects your stack