What’s Vulnerable › Vulnerabilities
CVE-2005-2088
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 20.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2005-07-05 · updated 2026-06-16
- Weakness: CWE-444
Description
The Apache HTTP server before 1.3.34, and 2.0.x before 2.0.55, when acting as an HTTP proxy, allows remote attackers to poison the web cache, bypass web application firewall protection, and conduct XSS attacks via an HTTP request with both a "Transfer-Encoding: chunked" header and a Content-Length header, which causes Apache to incorrectly handle and forward the body of the request in a way that causes the receiving server to process it as a separate HTTP request, aka "HTTP Request Smuggling."
Affected products
- Apache HTTP Server: from 2.0.35 before 2.0.55 — fixed in 2.0.55
- Debian Linux: 3.0, 3.1
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.0.55. Check the vendor advisory for mitigations.
References
- http://docs.info.apple.com/article.html?artnum=302847
- http://lists.trustix.org/pipermail/tsl-announce/2005-October/000354.html
- http://marc.info/?l=apache-httpd-announce&m=112931556417329&w=3
- http://seclists.org/lists/bugtraq/2005/Jun/0025.html
- http://secunia.com/advisories/14530
- http://secunia.com/advisories/17319
- http://secunia.com/advisories/17487
- http://secunia.com/advisories/17813
- http://secunia.com/advisories/19072
- http://secunia.com/advisories/19073
- http://secunia.com/advisories/19185
- http://secunia.com/advisories/19317
Get alerted when CVE-2005-2088 or the next vulnerability affects your stack