What’s Vulnerable › Vulnerabilities
CVE-2005-2103
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2005-08-16 · updated 2026-06-16
- Weakness: CWE-131
Description
Buffer overflow in the AIM and ICQ module in Gaim before 1.5.0 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via an away message with a large number of AIM substitution strings, such as %t or %n.
Affected products
- Gaim Project Gaim: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: Gaim Project Gaim 1.5.0. Check the vendor advisory for mitigations.
References
- http://gaim.sourceforge.net/security/?id=22
- http://www.novell.com/linux/security/advisories/2005_19_sr.html
- http://www.redhat.com/support/errata/RHSA-2005-589.html
- http://www.redhat.com/support/errata/RHSA-2005-627.html
- http://www.securityfocus.com/archive/1/426078/100/0/threaded
- http://www.securityfocus.com/bid/14531
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11477
- https://usn.ubuntu.com/168-1/
- http://gaim.sourceforge.net/security/?id=22
- http://www.novell.com/linux/security/advisories/2005_19_sr.html
- http://www.redhat.com/support/errata/RHSA-2005-589.html
- http://www.redhat.com/support/errata/RHSA-2005-627.html
Get alerted when CVE-2005-2103 or the next vulnerability affects your stack