What’s Vulnerable › Vulnerabilities
CVE-2005-2410
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2005-08-01 · updated 2026-06-16
Description
Format string vulnerability in the nm_info_handler function in Network Manager may allow remote attackers to execute arbitrary code via format string specifiers in a Wireless Access Point identifier, which is not properly handled in a syslog call.
Affected products
- GNOME NetworkManager: before 0.4.1 — fixed in 0.4.1
How to fix
Upgrade to a fixed version: GNOME NetworkManager 0.4.1. Check the vendor advisory for mitigations.
References
- http://lwn.net/Alerts/145678/
- http://mail.gnome.org/archives/networkmanager-list/2005-July/msg00196.html
- http://mail.gnome.org/archives/networkmanager-list/2005-July/msg00197.html
- http://lwn.net/Alerts/145678/
- http://mail.gnome.org/archives/networkmanager-list/2005-July/msg00196.html
- http://mail.gnome.org/archives/networkmanager-list/2005-July/msg00197.html
Get alerted when CVE-2005-2410 or the next vulnerability affects your stack