What’s Vulnerable › Vulnerabilities
CVE-2005-2700
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 30.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2005-09-06 · updated 2026-06-16
Description
ssl_engine_kernel.c in mod_ssl before 2.8.24, when using "SSLVerifyClient optional" in the global virtual host configuration, does not properly enforce "SSLVerifyClient require" in a per-location context, which allows remote attackers to bypass intended access restrictions.
Affected products
- Apache HTTP Server: from 2.0.35 before 2.0.55 — fixed in 2.0.55
- Canonical Ubuntu Linux: 4.10, 5.04
- Debian Linux: 3.0, 3.1
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.0.55. Check the vendor advisory for mitigations.
References
- http://lists.trustix.org/pipermail/tsl-announce/2005-October/000354.html
- http://marc.info/?l=apache-modssl&m=112569517603897&w=2
- http://marc.info/?l=bugtraq&m=112604765028607&w=2
- http://marc.info/?l=bugtraq&m=112870296926652&w=2
- http://people.apache.org/~jorton/CAN-2005-2700.diff
- http://secunia.com/advisories/16700
- http://secunia.com/advisories/16705
- http://secunia.com/advisories/16714
- http://secunia.com/advisories/16743
- http://secunia.com/advisories/16746
- http://secunia.com/advisories/16748
- http://secunia.com/advisories/16753
Get alerted when CVE-2005-2700 or the next vulnerability affects your stack