What’s Vulnerable › Vulnerabilities
CVE-2005-2837
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2005-09-07 · updated 2026-06-16
- Weakness: CWE-94
Description
Multiple eval injection vulnerabilities in PlainBlack Software WebGUI before 6.7.3 allow remote attackers to execute arbitrary Perl code via (1) Help.pm, (2) International.pm, or (3) WebGUI.pm.
Affected products
- Plainblack Webgui: before 6.7.3 — fixed in 6.7.3
How to fix
Upgrade to a fixed version: Plainblack Webgui 6.7.3. Check the vendor advisory for mitigations.
References
- http://www.plainblack.com/getwebgui/advisories/security-exploit-found-in-6.x-versions
- http://www.securityfocus.com/bid/14732
- http://www.plainblack.com/getwebgui/advisories/security-exploit-found-in-6.x-versions
- http://www.securityfocus.com/bid/14732
Get alerted when CVE-2005-2837 or the next vulnerability affects your stack