What’s Vulnerable › Vulnerabilities
CVE-2005-2946
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2005-09-16 · updated 2026-06-16
- Weakness: CWE-327
Description
The default configuration on OpenSSL before 0.9.8 uses MD5 for creating message digests instead of a more cryptographically strong algorithm, which makes it easier for remote attackers to forge certificates with a valid certificate authority signature.
Affected products
- Canonical Ubuntu Linux: 4.10, 5.04
- OpenSSL: before 0.9.8 — fixed in 0.9.8
How to fix
Upgrade to a fixed version: OpenSSL 0.9.8. Check the vendor advisory for mitigations.
References
- http://www.cits.rub.de/MD5Collisions/
- http://www.ubuntu.com/usn/usn-179-1
- https://bugzilla.ubuntu.com/show_bug.cgi?id=13593
- http://www.cits.rub.de/MD5Collisions/
- http://www.ubuntu.com/usn/usn-179-1
- https://bugzilla.ubuntu.com/show_bug.cgi?id=13593
Get alerted when CVE-2005-2946 or the next vulnerability affects your stack