What’s Vulnerable › Vulnerabilities
CVE-2005-2975
- Severity: high (CVSS 7.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2005-11-18 · updated 2026-06-16
- Weakness: CWE-399
Description
io-xpm.c in the gdk-pixbuf XPM image rendering library in GTK+ before 2.8.7 allows attackers to cause a denial of service (infinite loop) via a crafted XPM image with a large number of colors.
Affected products
- GNOME Gdkpixbuf: all versions
- GNOME Gtk: before 2.8.7 — fixed in 2.8.7
How to fix
Upgrade to a fixed version: GNOME Gtk 2.8.7. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/17522
- http://secunia.com/advisories/17538
- http://secunia.com/advisories/17562
- http://secunia.com/advisories/17588
- http://secunia.com/advisories/17591
- http://secunia.com/advisories/17592
- http://secunia.com/advisories/17594
- http://secunia.com/advisories/17615
- http://secunia.com/advisories/17657
- http://secunia.com/advisories/17710
- http://secunia.com/advisories/17770
- http://secunia.com/advisories/17791
Get alerted when CVE-2005-2975 or the next vulnerability affects your stack