What’s Vulnerable › Vulnerabilities
CVE-2005-2976
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2005-11-18 · updated 2026-06-16
- Weakness: CWE-190
Description
Integer overflow in io-xpm.c in gdk-pixbuf 0.22.0 in GTK+ before 2.8.7 allows attackers to cause a denial of service (crash) or execute arbitrary code via an XPM file with large height, width, and colour values, a different vulnerability than CVE-2005-3186.
Affected products
- GNOME Gdkpixbuf: 0.22
- GNOME Gtk: before 2.8.7 — fixed in 2.8.7
How to fix
Upgrade to a fixed version: GNOME Gtk 2.8.7. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/17522
- http://secunia.com/advisories/17538
- http://secunia.com/advisories/17562
- http://secunia.com/advisories/17592
- http://secunia.com/advisories/17594
- http://secunia.com/advisories/17615
- http://secunia.com/advisories/17657
- http://secunia.com/advisories/17710
- http://secunia.com/advisories/17770
- http://secunia.com/advisories/17791
- http://securitytracker.com/id?1015216
- http://support.avaya.com/elmodocs2/security/ASA-2005-229.pdf
Get alerted when CVE-2005-2976 or the next vulnerability affects your stack