What’s Vulnerable › Vulnerabilities
CVE-2005-3912
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2005-11-30 · updated 2026-06-16
Description
Format string vulnerability in miniserv.pl Perl web server in Webmin before 1.250 and Usermin before 1.180, with syslog logging enabled, allows remote attackers to cause a denial of service (crash or memory consumption) and possibly execute arbitrary code via format string specifiers in the username parameter to the login form, which is ultimately used in a syslog call. NOTE: the code execution might be associated with an issue in Perl.
Affected products
- Debian Linux: 3.1
- Webmin: from 1.100 before 1.180; from 1.200 before 1.250 — fixed in 1.180, 1.250
How to fix
Upgrade to a fixed version: Webmin 1.180, 1.250. Check the vendor advisory for mitigations.
References
- http://lists.immunitysec.com/pipermail/dailydave/2005-November/002685.html
- http://secunia.com/advisories/17749
- http://secunia.com/advisories/17817
- http://secunia.com/advisories/17878
- http://secunia.com/advisories/17942
- http://secunia.com/advisories/18101
- http://secunia.com/advisories/22556
- http://www.debian.org/security/2006/dsa-1199
- http://www.dyadsecurity.com/webmin-0001.html
- http://www.gentoo.org/security/en/glsa/glsa-200512-02.xml
- http://www.mandriva.com/security/advisories?name=MDKSA-2005:223
- http://www.novell.com/linux/security/advisories/2005_30_sr.html
Get alerted when CVE-2005-3912 or the next vulnerability affects your stack