What’s Vulnerable › Vulnerabilities
CVE-2006-0042
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2006-02-18 · updated 2026-06-16
Description
Unspecified vulnerability in (1) apreq_parse_headers and (2) apreq_parse_urlencoded functions in Apache2::Request (Libapreq2) before 2.07 allows remote attackers to cause a denial of service (CPU consumption) via unknown attack vectors that result in quadratic computational complexity.
Affected products
- Apache Software Foundation libapreq2: before 2.07 — fixed in 2.07
- Debian Linux: 3.0, 3.1
How to fix
Upgrade to a fixed version: Apache Software Foundation libapreq2 2.07. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/18846
- http://secunia.com/advisories/19139
- http://secunia.com/advisories/19658
- http://securityreason.com/securityalert/737
- http://svn.apache.org/viewcvs.cgi/httpd/apreq/tags/v2_07/CHANGES?rev=376998&view=markup
- http://www.debian.org/security/2006/dsa-1000
- http://www.gentoo.org/security/en/glsa/glsa-200604-08.xml
- http://www.securityfocus.com/bid/16710
- http://www.vupen.com/english/advisories/2006/0645
- https://exchange.xforce.ibmcloud.com/vulnerabilities/24917
- http://secunia.com/advisories/18846
- http://secunia.com/advisories/19139
Get alerted when CVE-2006-0042 or the next vulnerability affects your stack