What’s Vulnerable › Vulnerabilities
CVE-2006-10002: XML::Parser versions through 2.45 for Perl could overflow the pre-allocated buffer size cause a heap corruption (double free or corruption) and crashes
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-16
- Weakness: CWE-122
Description
XML::Parser versions through 2.45 for Perl could overflow the pre-allocated buffer size cause a heap corruption (double free or corruption) and crashes. A :utf8 PerlIO layer, parse_stream() in Expat.xs could overflow the XML input buffer because Perl's read() returns decoded characters while SvPV() gives back multi-byte UTF-8 bytes that can exceed the pre-allocated buffer size. This can cause heap corruption (double free or corruption) and crashes.
Affected products
- TODDR Xml::Parser: before 2.48 — fixed in 2.48
How to fix
Upgrade to a fixed version: TODDR Xml::Parser 2.48. Check the vendor advisory for mitigations.
References
- https://github.com/cpan-authors/XML-Parser/commit/56b0509dfc6b559cd7555ea81ee62e3622069255.patch
- https://github.com/cpan-authors/XML-Parser/issues/64
- https://metacpan.org/release/TODDR/XML-Parser-2.46/changes
- https://rt.cpan.org/Ticket/Display.html?id=19859
- http://www.openwall.com/lists/oss-security/2026/03/19/1
- http://www.openwall.com/lists/oss-security/2026/03/22/3
Get alerted when CVE-2006-10002 or the next vulnerability affects your stack