What’s Vulnerable › Vulnerabilities
CVE-2006-1547: Apache Struts 1 ActionForm Denial-of-Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-01-21
- EPSS: 54.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2006-03-30 · updated 2026-06-16
- Weakness: CWE-749
Description
ActionForm in Apache Software Foundation (ASF) Struts before 1.2.9 with BeanUtils 1.7 allows remote attackers to cause a denial of service via a multipart/form-data encoded form with a parameter name that references the public getMultipartRequestHandler method, which provides further access to elements in the CommonsMultipartRequestHandler implementation and BeanUtils.
Affected products
- Apache Struts: before 1.2.9 — fixed in 1.2.9
How to fix
Upgrade to a fixed version: Apache Struts 1.2.9. Check the vendor advisory for mitigations.
References
- http://issues.apache.org/bugzilla/show_bug.cgi?id=38534
- http://lists.suse.com/archive/suse-security-announce/2006-May/0004.html
- http://secunia.com/advisories/19493
- http://secunia.com/advisories/20117
- http://securitytracker.com/id?1015856
- http://struts.apache.org/struts-doc-1.2.9/userGuide/release-notes.html
- http://www.securityfocus.com/bid/17342
- http://www.vupen.com/english/advisories/2006/1205
- https://exchange.xforce.ibmcloud.com/vulnerabilities/25613
- http://issues.apache.org/bugzilla/show_bug.cgi?id=38534
- http://lists.suse.com/archive/suse-security-announce/2006-May/0004.html
- http://secunia.com/advisories/19493
Get alerted when CVE-2006-1547 or the next vulnerability affects your stack