What’s Vulnerable › Vulnerabilities

CVE-2006-1741

Description

Mozilla Firefox 1.x before 1.5 and 1.0.x before 1.0.8, Mozilla Suite before 1.7.13, and SeaMonkey before 1.0 allows remote attackers to inject arbitrary Javascript into other sites by (1) "using a modal alert to suspend an event handler while a new page is being loaded", (2) using eval(), and using certain variants involving (3) "new Script;" and (4) using window.__proto__ to extend eval, aka "cross-site JavaScript injection".

Affected products

How to fix

Upgrade to a fixed version: Mozilla Firefox 1.0.8; Mozilla Suite 1.7.13; Mozilla Seamonkey 1.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2006-1741 or the next vulnerability affects your stack