What’s Vulnerable › Vulnerabilities
CVE-2006-1865
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2006-04-21 · updated 2026-06-16
- Weakness: CWE-88
Description
Argument injection vulnerability in Beagle before 0.2.5 allows attackers to execute arbitrary commands via crafted filenames that inject command line arguments when Beagle launches external helper applications while indexing.
Affected products
- Beagle Project Beagle: before 0.2.5 — fixed in 0.2.5
How to fix
Upgrade to a fixed version: Beagle Project Beagle 0.2.5. Check the vendor advisory for mitigations.
References
- http://lists.seifried.org/pipermail/security/2006-April/013163.html
- http://scary.beasts.org/security/CESA-2006-002.html
- http://secunia.com/advisories/19778
- http://secunia.com/advisories/19781
- http://secunia.com/advisories/19897
- http://www.novell.com/linux/security/advisories/2006_04_28.html
- http://www.osvdb.org/24938
- http://www.securityfocus.com/bid/17611
- https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=189282
- https://exchange.xforce.ibmcloud.com/vulnerabilities/26104
- http://lists.seifried.org/pipermail/security/2006-April/013163.html
- http://scary.beasts.org/security/CESA-2006-002.html
Get alerted when CVE-2006-1865 or the next vulnerability affects your stack