What’s Vulnerable › Vulnerabilities
CVE-2006-3404
- Severity: medium (CVSS 5.1 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2006-07-06 · updated 2026-06-16
- Weakness: CWE-120
Description
Buffer overflow in the xcf_load_vector function in app/xcf/xcf-load.c for gimp before 2.2.12 allows user-assisted attackers to cause a denial of service (crash) and possibly execute arbitrary code via an XCF file with a large num_axes value in the VECTORS property.
Affected products
- GIMP: before 2.2.12 — fixed in 2.2.12
How to fix
Upgrade to a fixed version: GIMP 2.2.12. Check the vendor advisory for mitigations.
References
- http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=377049
- http://bugzilla.gnome.org/show_bug.cgi?id=346742
- http://secunia.com/advisories/20976
- http://secunia.com/advisories/20979
- http://secunia.com/advisories/21069
- http://secunia.com/advisories/21104
- http://secunia.com/advisories/21170
- http://secunia.com/advisories/21182
- http://secunia.com/advisories/21198
- http://secunia.com/advisories/21459
- http://secunia.com/advisories/23044
- http://security.gentoo.org/glsa/glsa-200607-08.xml
Get alerted when CVE-2006-3404 or the next vulnerability affects your stack