What’s Vulnerable › Vulnerabilities

CVE-2006-3747

Description

Off-by-one error in the ldap scheme handling in the Rewrite module (mod_rewrite) in Apache 1.3 from 1.3.28, 2.0.46 and other versions before 2.0.59, and 2.2, when RewriteEngine is enabled, allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via crafted URLs that are not properly handled using certain rewrite rules.

Affected products

How to fix

Upgrade to a fixed version: Apache HTTP Server 1.3.37, 2.0.59, 2.2.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2006-3747 or the next vulnerability affects your stack