What’s Vulnerable › Vulnerabilities

CVE-2006-3918

Description

http_protocol.c in (1) IBM HTTP Server 6.0 before 6.0.2.13 and 6.1 before 6.1.0.1, and (2) Apache HTTP Server 1.3 before 1.3.35, 2.0 before 2.0.58, and 2.2 before 2.2.2, does not sanitize the Expect header from an HTTP request when it is reflected back in an error message, which might allow cross-site scripting (XSS) style attacks using web client components that can send arbitrary headers in requests, as demonstrated using a Flash SWF file.

Affected products

How to fix

Upgrade to a fixed version: Apache HTTP Server 1.3.35. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2006-3918 or the next vulnerability affects your stack