What’s Vulnerable › Vulnerabilities
CVE-2006-4482
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2006-08-31 · updated 2026-06-16
- Weakness: CWE-787
Description
Multiple heap-based buffer overflows in the (1) str_repeat and (2) wordwrap functions in ext/standard/string.c in PHP before 5.1.5, when used on a 64-bit system, have unspecified impact and attack vectors, a different vulnerability than CVE-2006-1990.
Affected products
- Canonical Ubuntu Linux: 5.04, 5.10, 6.06
- Debian Linux: 3.1
- PHP: before 5.1.5 — fixed in 5.1.5
How to fix
Upgrade to a fixed version: PHP 5.1.5. Check the vendor advisory for mitigations.
References
- http://cvs.php.net/viewvc.cgi/php-src/ext/standard/string.c?r1=1.445.2.14.2.10&r2=1.445.2.14.2.11
- http://rhn.redhat.com/errata/RHSA-2006-0688.html
- http://secunia.com/advisories/21546
- http://secunia.com/advisories/21768
- http://secunia.com/advisories/22004
- http://secunia.com/advisories/22039
- http://secunia.com/advisories/22069
- http://secunia.com/advisories/22225
- http://secunia.com/advisories/22440
- http://secunia.com/advisories/22487
- http://secunia.com/advisories/22538
Get alerted when CVE-2006-4482 or the next vulnerability affects your stack